You have a Revit model which you would like to upload to at 3drepo.io but is failing to upload. Don't you worry, it might simply be the case because you haven't properly set up the 3D view and its properties. To fix the issue, open your version of Revit and follow the steps below before uploading the file again to 3drepo.io.

When you upload a Revit model at 3drepo.io remember to always follow the best practice. In some cases, you may experience model upload failures. If your Revit model is not 2021 version (which we currently don't support), then here are the most common issues that are easy to fix:

Issue 1:

Model uploaded successfully but some geometry is missing

Always, remember to create a 3D view called 3D Repo. We use it to generate your model's geometry, so whatever is visible in that view will become available in 3D Repo. If your model contains no 3D view called 3D Repo, then we will use any other available 3D view.

Issue 2:

Model uploaded successfully but all of my geometry is dark grey

This happens when the 3D view used to generate model geometry is set to hidden or wireframe styles. 3D views in Revit need to be set to a Shaded style, in order to apply element colours in 3D Repo. It is easy to fix it in Revit, just head over to the Visual Style of your 3D view and set it as Shaded. You can also change the Detail level of your 3D view between Coarse, Medium & Fine.

Issue 3:

Half or at times parts of my model are missing

If some model areas or a large part of your model are missing, this might simply mean that there is a Section Box. Make sure that prior to uploading your model to 3D Repo the 3D view in Revit contains no section box. In some cases, you might want to use it for splitting up your models.

In the 3D View's properties panel untick Section Box. Do this to disable the Section Box if you wish to upload the entire model rather than a specific part of it

Did this answer your question?